Can I Run LEGO Harry Potter: Years 5-7: system requirements

LEGO Harry Potter: Years 5-7
Developer:
Traveller's Tales
Publisher:
Warner Bros Interactive Entertainment
Release date:
Metacritic rating:
80 / 100
Our user rating:
2.8 / 5

Official system requirements

These are the PC specs advised by developers to run at minimal and recommended settings. Those requirements are usually very approximate, but still can be used to determine the indicative hardware tier you need to play the game.


Minimum system requirements

Graphics card:
Shader Model 3 graphics card (NVIDIA GeForce 6800, 7800, 8xxx or better; ATI X1950 or better)
CPU:
Dual Core CPU @ 2GHz (Pentium D or better)
Memory:
1GB RAM
File size:
8.5 GB free HDD space
Operating system:
Windows XP SP3 Vista or Windows 7
DirectX:
no data

Recommended system requirements

Graphics card:
no data
CPU:
no data
Memory:
no data
File size:
no data
Operating system:
no data
DirectX:
no data

Minimum system requirements

Recommended system requirements

Graphics card:
Shader Model 3 graphics card (NVIDIA GeForce 6800, 7800, 8xxx or better; ATI X1950 or better)
Graphics card:
no data
CPU:
Dual Core CPU @ 2GHz (Pentium D or better)
CPU:
no data
Memory:
1GB RAM
Memory:
no data
File size:
8.5 GB free HDD space
File size:
no data
Operating system:
Windows XP SP3 Vista or Windows 7
Operating system:
no data
DirectX:
no data
DirectX:
no data

User rating

Here you can see the user rating of the game, as well as rate it yourself.


2.8 9 ratings

Rate LEGO Harry Potter: Years 5-7 on a scale of 1 to 5:

  • 1
  • 2
  • 3
  • 4
  • 5

Other games by Traveller's Tales

We have the requirements for some other games developed by the same company.

Games similar to LEGO Harry Potter: Years 5-7

Check out the required PC specs of some other popular games similar to the one reviewed.

Comments

Here you can ask questions about LEGO Harry Potter: Years 5-7, agree or disagree with our evaluations, or report errors and inaccuracies on the site.