LEGO Harry Potter: Years 1-4 system requirements

Hide your gaming PC configuration
Graphics card
Processor
Memory, GB

Minimum
39%
Recommended
32%
Minimum
39%
Recommended
32%

What games can I run

Developer:
TT Games
Publisher:
Warner Bros Interactive Entertainment
Release date:
Metacritic rating:
79
LEGO Harry Potter: Years 1-4
2010

Official LEGO Harry Potter: Years 1-4 system requirements

These are the PC specs advised by developers to run at minimal and recommended settings. Those requirements are usually very approximate, but still can be used to determine the indicative hardware tier you need to play the game.

Yes Minimum system requirements
No Recommended system requirements
Graphics card: ATI X1300/NVIDIA GeForce FX 5800 (256 MB RAM)
Graphics card: ATI HD 2900/NVIDIA GeForce 8800
CPU: Intel P4 1.8 GHz/AMD Athlon XP 2200+
CPU: Intel Core 2 Duo/AMD Athlon 64, 2.8GHz
Yes Memory: 512 MB RAM
No Memory: 2 GB RAM
File size: no data
File size: no data
Operating system: Windows XP/Vista http://gamesystemrequirements.com/
Operating system: Windows XP/Vista
DirectX: no data
DirectX: no data
Yes Minimum system requirements
Graphics card: ATI X1300/NVIDIA GeForce FX 5800 (256 MB RAM)
CPU: Intel P4 1.8 GHz/AMD Athlon XP 2200+
Yes Memory: 512 MB RAM
File size: no data
Operating system: Windows XP/Vista http://gamesystemrequirements.com/
DirectX: no data
No Recommended system requirements
Graphics card: ATI HD 2900/NVIDIA GeForce 8800
CPU: Intel Core 2 Duo/AMD Athlon 64, 2.8GHz
No Memory: 2 GB RAM
File size: no data
Operating system: Windows XP/Vista
DirectX: no data

User rating

Here you can see the user rating of the game, as well as rate it yourself.

3.0
4 ratings

Rate the game on a scale of 1 to 5:

Games similar to LEGO Harry Potter: Years 1-4

Check out the required PC specs of some other popular games similar to the one reviewed.

Comments